Important Message for Windows Vista or Internet Explorer Version 9 Users!

Effective November 17th, Paragon will no longer be compatible with Windows Vista or Internet Explorer Version 9. If you are using Windows Vista, or Internet Explorer 9, you will need to upgrade your system to continue accessing Paragon. Please contact our tech support department or your office IT staff, for information on your upgrade options. Continue reading